7.8/10 (11 أصوات )




  • مرات التنزيل: 123
  • متطلبات التشغيل:
  • الحجم:
  • الترخيص:
  • الاصدار : VTE
  • اضيف في: 0000-00-00 00:00:00
  • اخر تحديث: 28/09/2010
  • الموقع علي الانترنت:






Description




VTE library inserts terminal capability strings into a tree of tables.You could say that VTE is something of a research project of mine, based on the simple question: "if programs can use a termcap file (through either libtermcap or curses or ncurses) to determine how to drive a terminal, why can't a terminal emulator use a termcap file to determine how to behave?"Update: the answer is most likely "because applications which use curses have more detailed information than that which is found in termcap".What does VTE include?VTE includes a library (libvte) which implements such a terminal emulator widget for GTK+ 2.2/2.4, and a sample application (vte) which wraps that widget in a GTK window. Because I'm more concerned with whether or not it works, all settings are hard-coded to whatever I needed to test the last time I touched it. If you actually want to use the widget to get work done, you should probably be using gnome-terminal.How does it work?The VTE library inserts terminal capability strings into a tree of tables, and then uses it to determine if data received from a pseudo-terminal is a control sequence or just random data. The sample program "interpret" illustrates more or less what the widget sees after it filters incoming data. Requirements:

· Font Configuration Library
What's New in This Release: [ read full changelog ]

· Make vte parallel-buildable with gtk 2 and gtk 3

Bugs fixed:
· Bug 617690 Setting default fg color should not cancel underline
· Bug 614658 text selection with mouse is buggy when using the shift key
· Bug 618749 set terminal widget background color to terminal background
· Bug 601926 Don't hardcode meta to alt
· Bug 618097 Broken backtab (cbt)
· Bug 621298 Cursor invisible (plain black) in (xfce) Terminal & terminator
· Bug 626676 Cleanup vte_terminal_determine_colors
· Bug 620493 strict aliasing warning
· Translation updates









التعليقات علي VTE 0.26.0
اضافة تعليق

تعليقات الفيسبوك

تعليقات الموقع